Skip to main content
← All vulnerabilities
CVE-2025-34192

Vasion Print (formerly PrinterLogic) Usage of Outdated and Unsupported OpenSSL Version

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 22.0.893, 20.0.2140
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: partial

Summary

Vasion Print (formerly PrinterLogic) Virtual Appliance Host versions prior to 22.0.893 and Application versions prior to 20.0.2140 (macOS/Linux client deployments) are built against OpenSSL 1.0.2h-fips (released May 2016), which has been end-of-life since 2019 and is no longer supported by the OpenSSL project. Continued use of this outdated cryptographic library exposes deployments to known vulnerabilities that are no longer patched, weakening the overall security posture. Affected daemons may emit deprecation warnings and rely on cryptographic components with unresolved security flaws, potentially enabling attackers to exploit weaknesses in TLS/SSL processing or cryptographic operations. This vulnerability has been identified by the vendor as: V-2023-021 — Out-of-Date OpenSSL Library.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: partial

  3. Record last updated

Affected versions

  • Vasion Print Virtual Appliance Host

    fixed in 22.0.893

  • Vasion Print Application

    fixed in 20.0.2140

References 4

help.printerlogic.com

pierrekim.github.io

vulncheck.com