Linksys Routers E/WAG/WAP/WES/WET/WRT-Series
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 1.0.06, 1.0.05, 2.0.00, 2.1.03, 1.0.04
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- 1 Metasploit module, 1 proof of concept on GitHub
- Exploitation: poc
- Automatable: yes
- Technical impact: total
Summary
An OS command injection vulnerability exists in various models of E-Series Linksys routers via the /tmUnblock.cgi and /hndUnblock.cgi endpoints over HTTP on port 8080. The CGI scripts improperly process user-supplied input passed to the ttcp_ip parameter without sanitization, allowing unauthenticated attackers to inject shell commands. This vulnerability was reported to be exploited in the wild by the "TheMoon" worm in 2014 to deploy a MIPS ELF payload, enabling arbitrary code execution on the router. Additionally, this vulnerability may affect other Linksys products to include, but not limited to, WAG/WAP/WES/WET/WRT-series router models and Wireless-N access points and routers. Exploitation evidence was observed by the Shadowserver Foundation on 2025-02-06 UTC.
Timeline
- CVE published
- CISA SSVC assessment
Exploitation: poc · Automatable: yes · Technical impact: total
- Record last updated
- EPSS reached 10%
FIRST estimates at least a 10% chance of exploitation in the next 30 days
Affected versions
- Linksys E4200
fixed in 1.0.06
- Linksys E3200
fixed in 1.0.05
- Linksys E3000
fixed in 1.0.06
- Linksys E2500 v1/v2
fixed in 2.0.00
- Linksys E2100L v1
through 1.0.05
- Linksys E2000
0
- Linksys E1550
through 1.0.03
- Linksys E1500 v1
fixed in 1.0.06
- Linksys E1200 v1
through 1.0.04
- Linksys E1000 v1
fixed in 2.1.03
- Linksys E900 v1
fixed in 1.0.04