Skip to main content
← All vulnerabilities
CVE-2025-32974GHSA-MVGM-3RW2-7J4R

org.xwiki.platform:xwiki-platform-security-requiredrights-default required rights analysis doesn't consider TextAreas with default content type

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 15.10.8, 16.2.0
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: poc
  • Automatable: no
  • Technical impact: total

Summary

XWiki is a generic wiki platform. In versions starting from 15.9-rc-1 to before 15.10.8 and from 16.0.0-rc-1 to before 16.2.0, the required rights analysis doesn't consider TextAreas with default content type. When editing a page, XWiki warns since version 15.9 when there is content on the page like a script macro that would gain more rights due to the editing. This analysis doesn't consider certain kinds of properties, allowing a user to put malicious scripts in there that will be executed after a user with script, admin, or programming rights edited the page. Such a malicious script could impact the confidentiality, integrity and availability of the whole XWiki installation. This issue has been patched in versions 15.10.8 and 16.2.0.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: poc · Automatable: no · Technical impact: total

  3. Record last updated

Affected versions

  • xwiki xwiki-platform

    From 15.9-rc-1 · fixed in 15.10.8; From 16.0.0-rc-1 · fixed in 16.2.0

  • org.xwiki.platform:xwiki-platform-security-requiredrights-defaultMaven

    From 15.9-rc-1 · fixed in 15.10.8

  • org.xwiki.platform:xwiki-platform-security-requiredrights-defaultMaven

    From 16.0.0-rc-1 · fixed in 16.2.0

References 3

GitHub · xwiki/xwiki-platform

jira.xwiki.org