Skip to main content
← All vulnerabilities
CVE-2025-31682DRUPAL-CONTRIB-2025-011GHSA-36VV-Q5JV-94CJ

Google Tag - Moderately critical - Cross Site Scripting - SA-CONTRIB-2025-011

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 1.8.0, 2.0.8
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: partial

Summary

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Drupal Google Tag allows Cross-Site Scripting (XSS).This issue affects Google Tag: from 0.0.0 before 1.8.0, from 2.0.0 before 2.0.8.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: partial

  3. Record last updated

Affected versions

  • Drupal Google Tag

    From 0.0.0 · fixed in 1.8.0; From 2.0.0 · fixed in 2.0.8

  • drupal/google_tagPackagist

    fixed in 1.8.0; From 2.0.0 · fixed in 2.0.8

  • drupal/google_tagPackagist

    fixed in 1.8.0

  • drupal/google_tagPackagist

    From 2.0.0 · fixed in 2.0.8

References 1

drupal.org