Skip to main content
← All vulnerabilities
CVE-2025-31675DRUPAL-CORE-2025-004BIT-DRUPAL-2025-31675GHSA-M4WJ-HHWJ-47QP

Drupal core - Moderately critical - Cross Site Scripting - SA-CORE-2025-004

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 10.3.14, 10.4.5, 11.0.13, 11.1.5
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: partial

Summary

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Drupal Drupal core allows Cross-Site Scripting (XSS).This issue affects Drupal core: from 8.0.0 before 10.3.14, from 10.4.0 before 10.4.5, from 11.0.0 before 11.0.13, from 11.1.0 before 11.1.5. It also affects the Drupal 7 module from versions 7.x-1.0 through 7.x-1.12.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: partial

  3. Record last updated

Affected versions

  • Drupal Drupal core

    From 8.0.0 · fixed in 10.3.14; From 10.4.0 · fixed in 10.4.5; From 11.0.0 · fixed in 11.0.13; From 11.1.0 · fixed in 11.1.5

  • Drupal Link

    From 7.x-1.0 · through 7.x-1.12

  • drupal/corePackagist

    From 8.0.0 · fixed in 10.3.14; From 10.4.0 · fixed in 10.4.5; From 11.0.0 · fixed in 11.0.13; From 11.1.0 · fixed in 11.1.5

  • drupal/corePackagist

    From 8.0.0 · fixed in 10.3.14

  • drupal/corePackagist

    From 10.4.0 · fixed in 10.4.5

  • drupal/corePackagist

    From 11.0.0 · fixed in 11.0.13

  • drupal/corePackagist

    From 11.1.0 · fixed in 11.1.5

References 3

drupal.org

herodevs.com

d7es.tag1.com