Skip to main content
← All vulnerabilities
CVE-2025-31650GHSA-3P2H-WQQ4-WF4HBIT-TOMCAT-2025-31650

Apache Tomcat: DoS via malformed HTTP/2 PRIORITY_UPDATE frame

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 9.0.104, 10.1.40, 11.0.6
1 on Exploit-DB, 6 proofs of concept on GitHub
  • Exploitation: none
  • Automatable: yes
  • Technical impact: partial

Summary

Improper Input Validation vulnerability in Apache Tomcat. Incorrect error handling for some invalid HTTP priority headers resulted in incomplete clean-up of the failed request which created a memory leak. A large number of such requests could trigger an OutOfMemoryException resulting in a denial of service. This issue affects Apache Tomcat: from 9.0.76 through 9.0.102, from 10.1.10 through 10.1.39, from 11.0.0-M2 through 11.0.5. The following versions were EOL at the time the CVE was created but are known to be affected: 8.5.90 though 8.5.100. Users are recommended to upgrade to version 9.0.104, 10.1.40 or 11.0.6 which fix the issue.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: yes · Technical impact: partial

  3. Public exploit on Exploit-DB

    EDB-52318

  4. Record last updated
  5. EPSS reached 10%

    FIRST estimates at least a 10% chance of exploitation in the next 30 days

Affected versions

  • Apache Software Foundation Apache Tomcat

    From 9.0.76 · through 9.0.102; From 10.1.10 · through 10.1.39; From 11.0.0-M2 · through 11.0.5; From 8.5.90 · through 8.5.100

  • org.apache.tomcat:tomcat-coyoteMaven

    From 9.0.76 · fixed in 9.0.104

  • org.apache.tomcat:tomcat-coyoteMaven

    From 10.1.10 · fixed in 10.1.40

  • org.apache.tomcat:tomcat-coyoteMaven

    From 11.0.0-M2 · fixed in 11.0.6

  • org.apache.tomcat.embed:tomcat-embed-coreMaven

    From 9.0.76 · fixed in 9.0.104

  • org.apache.tomcat.embed:tomcat-embed-coreMaven

    From 10.1.10 · fixed in 10.1.40

  • org.apache.tomcat.embed:tomcat-embed-coreMaven

    From 11.0.0-M2 · fixed in 11.0.6

  • org.apache.tomcat:tomcat-coyoteMaven

    From 8.5.0 · through 8.5.100

  • org.apache.tomcat.embed:tomcat-embed-coreMaven

    From 8.5.0 · through 8.5.100

References 8

lists.apache.org

Exploit-DB

GitHub · B1gN0Se/Tomcat-CVE-2025-31650

GitHub · absholi7ly/TomcatKiller-CVE-2025-31650

GitHub · assad12341/Dos-exploit-

GitHub · obscura-cert/CVE-2025-31650

GitHub · sattarbug/Analysis-of-TomcatKiller---CVE-2025-31650-Exploit-Tool

GitHub · tunahantekeoglu/CVE-2025-31650