Skip to main content
← All vulnerabilities
CVE-2025-31363GO-2025-3622GHSA-9H6J-4FFX-CM84

Data exfiltration via AI plugin Jira tool

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 9.11.10+incompatible, 10.4.3+incompatible, 10.5.1+incompatible, 8.0.0-20250218121836-2b5275d87136, 10.5.1, and 2 more
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: partial

Summary

Mattermost versions 10.4.x <= 10.4.2, 10.5.x <= 10.5.0, 9.11.x <= 9.11.9 fail to restrict domains the LLM can request to contact upstream which allows an authenticated user to exfiltrate data from an arbitrary server accessible to the victim via performing a prompt injection in the AI plugin's Jira tool.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: partial

  3. Record last updated

Affected versions

  • Mattermost Mattermost

    From 10.4.0 · through 10.4.2; From 9.11.0 · through 9.11.9

  • github.com/mattermost/mattermost-serverGo

    From 9.11.0+incompatible · fixed in 9.11.10+incompatible; From 10.4.0+incompatible · fixed in 10.4.3+incompatible; From 10.5.0+incompatible · fixed in 10.5.1+incompatible

  • github.com/mattermost/mattermost-server/v5Go

    All versions

  • github.com/mattermost/mattermost-server/v6Go

    All versions

  • github.com/mattermost/mattermost/server/v8Go

    fixed in 8.0.0-20250218121836-2b5275d87136

  • github.com/mattermost/mattermost/server/v8Go

    From 10.5.0 · fixed in 10.5.1

  • github.com/mattermost/mattermost/server/v8Go

    From 10.4.0 · fixed in 10.4.3

  • github.com/mattermost/mattermost/server/v8Go

    From 9.11.0 · fixed in 9.11.10

References 1

mattermost.com