Skip to main content
← All vulnerabilities
CVE-2025-30661

Junos OS: Low-privileged user can cause script to run as root, leading to privilege escalation

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 23.2R2-S4, 23.4R2-S5, 24.2R2-S1
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: total

Summary

An Incorrect Permission Assignment for Critical Resource vulnerability in line card script processing of Juniper Networks Junos OS allows a local, low-privileged user to install scripts to be executed as root, leading to privilege escalation. A local user with access to the local file system can copy a script to the router in a way that will be executed as root, as the system boots. Execution of the script as root can lead to privilege escalation, potentially providing the adversary complete control of the system. This issue only affects specific line cards, such as the MPC10, MPC11, LC4800, LC9600, MX304-LMIC16, SRX4700, and EX9200-15C. This issue affects Junos OS: * from 23.2 before 23.2R2-S4,  • from 23.4 before 23.4R2-S5,  • from 24.2 before 24.2R2-S1,  • from 24.4 before 24.4R1-S3, 24.4R2. This issue does not affect versions prior to 23.1R2.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: total

  3. Record last updated

Affected versions

  • Juniper Networks Junos OS

    From 23.2 · fixed in 23.2R2-S4; From 23.4 · fixed in 23.4R2-S5; From 24.2 · fixed in 24.2R2-S1

References 2

supportportal.juniper.net

GitHub · orangecertcc/security-research