Skip to main content
← All vulnerabilities
CVE-2025-30213GHSA-V342-4XR9-X3Q3PYSEC-2026-1393

Frappe has Possibility of Remote Code Execution due to improper validation

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 14.91.0, 15.52.0
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: total

Summary

Frappe is a full-stack web application framework. Prior to versions 14.91.0 and 15.52.0, a system user was able to create certain documents in a specific way that could lead to remote code execution. Versions 14.9.1 and 15.52.0 contain a patch for the vulnerability. There's no workaround; an upgrade is required.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: total

  3. Record last updated

Affected versions

  • frappe frappe

    fixed in 14.91.0; From 15.0.0 · fixed in 15.52.0

  • frappePyPI

    fixed in 14.91.0

  • frappePyPI

    From 15.0.0 · fixed in 15.52.0

  • frappePyPI

    fixed in 14.91.0; From 15.0.0 · fixed in 15.52.0

References 1

GitHub · frappe/frappe